SSL VPN disconnects - Unknown Error Code 10060

XTM525 running 12.1.3. VPN Client 12.5.3

I am looking for advice on how to troubleshoot random VPN client disconnects. I have seen this log entry on two different remote users VPN logs who were randomly disconnected.

Here are the logs. You can see this user connected at 07:29 and then the unknown error occurs at 11:23. What is unknown error code 10060?

2020-09-23T07:29:40.610 SSLVPN Connected
2020-09-23T11:23:44.253 OVPN:>LOG:1600885424,N,read TCP_CLIENT: Unknown error (code=10060)

2020-09-23T11:23:44.254 OVPN:>LOG:1600885424,N,Connection reset, restarting [-1]

2020-09-23T11:23:44.254 OVPN:>LOG:1600885424,I,SIGUSR1[soft,connection-reset] received, process restarting

2020-09-23T11:23:44.255 Does not allow reconnectiong

Best Answer

Answers

  • James_CarsonJames_Carson Moderator, WatchGuard Representative

    Bruce is right on the cause, likely just a reset or timed out connection.
    If the users are on problematic internet connections, enabling the option to allow them to automatically reconnect can be helpful for mitigating that type of issue.

    It'd be interesting to see if there are any logs related to the user(s) around the time that issue happened. If this keeps happening, I'd suggest checking there too. If the problem persists, or happens a lot, I'd suggest opening a support case so that our team can look into it with you.

    -James Carson
    WatchGuard Customer Support

  • Thank you both. I was unaware that the mobile VPN SSL client used the OpenVPN standard. That is good info. I really just wanted to rule out an issue with my Firebox VPN services. This sounds like an issue on the client side and we will focus on that for now. Thank you!

Sign In to comment.