How to block Senders that have a space in the "FROM" name

Hi everybody, since few day we've received spam in our exchange server.
those mails are not marked as SPAM.
The Name address of these mails look like this "arturmartin @ our domain name" (it's our domain name , and the From is random mail address from .ru .nl .cn ...

Is there a way in smtp proxy to block mail wtih a space in the sender name.
All rules that i've done with "from:" don't work.

Thank you for helping me

Answers

  • You can try using RegEx instead of Pattern Match.

    Try this:
    (?i)(@\s.;mydomain.com)
    This should match:
    user @ mydomain.com

    For:
    user @ mydomain com
    Try:
    (?i)(@\s.;mydomain\scom)

  • DAMN forum is changing posted characters.
    No idea why!!!!!!!!!!!!
    remove the semicolon from the above strings prior to mydomain

  • Hi Bruce,

    I wrote this in my firewall config a few week ago.
    It seems to work.

    thanks a lot for your help

  • James_CarsonJames_Carson WatchGuard Representative

    @Bruce_Briggs

    Try using the markdown features like the code tag. It makes the weird formatting go away. [email protected] and :D :P should show up without any weird formatting

    -James Carson
    WatchGuard Customer Support

  • edited November 12

    So we now need to learn Markdown in order to post many things correctly here ????
    NOT user friendly.

    Is there no default option which could be set for these boards to allow text to be not modified unless using Markdown ???

  • James_CarsonJames_Carson WatchGuard Representative

    Hi @Bruce_Briggs

    I can certainly have the team that manages the forums look into it -- the markdown just lets you do it now by adding a tag.

    I'll see what I can do.

    -James Carson
    WatchGuard Customer Support

  • edited November 12

    Thanks

    Also, can you post a link to a Markdown doc which shows the meaning of :D :P

    Note that colon D displays as an imogee on this board

  • James_CarsonJames_Carson WatchGuard Representative

    Hi @Bruce_Briggs
    It's a link at the bottom of the text box that pops up when you post.
    It links here:
    https://en.wikipedia.org/wiki/Markdown

    -James Carson
    WatchGuard Customer Support

  • But when I search that site for :D (colum D) no hits are found.
    So what am I missing?

  • James_CarsonJames_Carson WatchGuard Representative
    edited November 13

    Hi Bruce,

    You have to put a formatting tag around it. There isn't anything specific for : D.


    code> :D /code >

    (add the open < to make that work)

    -James Carson
    WatchGuard Customer Support

Sign In to comment.