Safe Search


Does enabling Enforce Safe Search no longer work for Google?
I can search images.google.com for anything and all kinds of NSFW images appear, but for Bing, Yahoo, and YouTube I get rejected and am unable to turn Safe Search off in the browser.
Anyone else notice this?

  • Doug

It's usually something simple.


  • Options

    Are you using Chrome browser?

    How to prevent connections from Chrome browsers that bypass WebBlocker and SafeSearch restrictions with QUIC protocol?

  • Options

    Using Brave, which is a Chrome-esque browser.
    Folllowed the instructions in the article you posted. Disabled the Experimental QUIC Protocol in the browser, reloaded the browser, same result. NSFW :-(

    Per the article, I created a policy to block UDP ports 80 & 443, placed it at the top of my policies and still NSFW images.

    I'm using a private window when testing so no browsing data is saved.

    It's usually something simple.

  • Options

    Another go.. The last post got "lost".

    I have noticed this for a while. The only way that I can get it work properly is to use A record entries in my local DNS to point google.com (or google.com.au) to the IP address of forcesafesearch.google.com. See https://support.opendns.com/hc/en-us/articles/227986807-How-to-Enforcing-Google-SafeSearch-YouTube-and-Bing for more information.

    You must clear the cache on the DNS server for this to work properly.

    Adrian from Australia

  • Options

    Great work around solution.
    Instead of creating new Zones in my DNS infrastructure I would rather just check the box in the Proxy and have it work. Don't want to be mean, but isn't that why I purchased the Security Subscriptions in the first place?

    It's usually something simple.

  • Options

    The question is this a firewall problem or a Google problem?
    If a Google problem, then there is little or nothing that the firewall can really do here.

    Consider opening a support incident to get WG help in looking at this.

Sign In to comment.