VPN with SSL works with Wi-Fi but issues on hardwired Ethernet

When I'm on WiFi the VPNSSL works as expected.

When I switched to a hard wire Ethernet cable (same subnet as the WiFi) and then turn on VPNSSL, browsing to the exact same https website gives a cert error.

I've got 2 separate Ethernet ports for my laptop. One on the laptop itself and one on a docking hub. Both have the same issue so I don't think it's driver related.

Windows 10 Pro
Watchguard VPN with SSL setup:
Routed VPN traffic
Force all client traffic through tunnel

I'm happy to do more reading if someone can point me to an article explaining how to correct this.

Grateful for any direction.
Rois

Comments

  • James_CarsonJames_Carson WatchGuard Representative

    Hi @Gimecoffee

    When you see the cert error, what cert is being presented? Is it one from the firewall or something else?

    What you're describing sounds like something may be doing some sort of content inspection -- do you have any AV/Firewall programs on your PC that you can check?

    Without seeing logs and certs, it'd be hard to diagnose this specifically, if this persists, I'd suggest opening a case by using the support center link on the top right of this page so that a technician can help.

    Thank you,

    -James Carson
    WatchGuard Customer Support

  • It's a self signed cert so I'm guessing it has to be coming off the Watchguard box instead of the server being accessed.

    Maybe another clue after some testing. This is one of 2 domains where I have an external DNS server set to the external firewall IP (firewall forwards to an internal server). When you are connected to the VPNSSL our internal DNS server give out internal IP addresses for these 2 domains.

    My Internal only websites are not having a cert error but they are NOT listed on the external DNS server.

    If this new bit of info doesn't trigger a new option to look into I'll put a help ticket in with Watchguard. Just doesn't seam right that connecting via Ethernet cable vs WIFI to the exact same local network should make a difference when turning on the VPN connections.

    Thanks
    Rois

Sign In to comment.