User needs to reinstall SSL Agent to be able to connect


One client has a problem with its computer, because it is not able to connect with the SSL Agent. He said me that just when he uninstall and reinstall the Agent is able to connect again. But it is manual process.

I have tried to upgrade the Agent SSL to the new version (12.5) and it didn't work.

I would like to know what components do I need to check (for example: .NET Framework, OS versions, network adapters,...). I have searched in HelpCenter and another blogs, but the tips are too general, it is not something specific.

Thanks in advanced.


Best Answer


  • james.carsonjames.carson Moderator, WatchGuard Representative

    Hi @Iscott

    I'd suggest checking to see if any other VPN type apps (especially OpenVPN based ones) are installed. They may be conflicting with the SSLVPN application.

    It's also a good idea to make sure there aren't any software firewall programs interfering with it -- check to see if any of those are flagging it or logging anything.

    If the issue continues, I'd suggest opening a support case by clicking support center at the top right of this page, so a technician can take a closer look at this for you.

    Thank you,

    -James Carson
    WatchGuard Customer Support

  • edited September 2019

    I always have to install the SSLVPN agent by running it as administrator for any Windows 10 system. Failing to do so (running installer as admin) prevents the TAP driver from installing.

    Another user suggested deleting a local folder, and that has solved my connection issues so far. He recommended deleting the "C:\Users\username\AppData\Roaming\WatchGuard" folder, but that also deletes preferences for FSM and other stuff, so I just deleted the "C:\Users\username\AppData\Roaming\WatchGuard\Mobile VPN" folder. So far, so good!

    Gregg Hill

  • Thanks for your help @James_Carson and @Greggmh123 . I will try your recommendations.


  • Not sure if you resolved this or not. We had a problem similar this and we found a solution here. It ended up being the TAP driver. Complete solution at the StarNet Technologies link above.

Sign In to comment.