Crash WatchGuard Mobile VPN wit SSL cliente 12.2

Hi Community,
Every time I execute WatchGuard Mobile VPN wit SSL client 12.2 on win10 pro, application crashes and a dmp file is generated. The crash ocurrs before "Waiting for connection" is shown. This windows account user can execute programs but account has not administrator privileges. With an administrator user, app run succesfully all times.
Any help would be appreciated
Thanks

Comments

  • I have had HORRIBLE experience with the SSLVPN client for a month or so now on my laptop running Win 10 Pro 64-bit. My T35-W is now on 12.5.1 firmware, and the SSLVPN client is the one downloaded via the SSLVPN login page.

    I either get the same crashes you noted, or it flips right back to the login prompt after authenticating and confirming the Duo Security 2FA prompt. If I just log into the SSLVPN login page and authenticate and confirm the Duo prompt on my phone, it connects every single time to the login page. Trying to connect to the SSLVPN itself via the client is a hit-or-miss.

    I have updated and downgraded my laptop's wireless card drivers, and I have removed/reinstalled the SSLVPN client multiple times, always installing it by running as admin and with AV software disabled during installation and connection attempts.

    Still trying to narrow it down!

    Gregg Hill

  • I had this problem too. What I did was going into c:\users\username\appdata\roaming\ and delete the watchguard folder. It will create a new one. By the way anyone know how to read the dmp file? Notepad just shows garbage.

  • RalphRalph WatchGuard Representative

    Hello all,

    We've been unable to reproduce the crash with the information provided in this thread so far. Please open a support case and reference this thread.

    thanks

  • edited September 2019

    It has been only a few days, but so far, KevCar's suggestion to delete the C:\Users\Gregg\AppData\Roaming\WatchGuard folder has stopped my SSLVPN client from crashing.

    I just realized that deleting the whole C:\Users\Gregg\AppData\Roaming\WatchGuard folder deletes FSM preferences as well, so I will just try deleting the "C:\Users\Gregg\AppData\Roaming\WatchGuard\Mobile VPN" folder if it happens again.

    Gregg Hill

  • RalphRalph WatchGuard Representative

    Hello all,

    Mobile with SSL 12.5.2 resolves this client crash. Please let us know if you see any issues on the new version.

  • That´s good to hear. It´s been over a year ago, i reported this bug and spend quite some time with support without any luck. Good it´s fixed, just to bad, it took so long.

  • edited February 6

    Hi

    Exactly same here, crashing on waiting for connection, running 12.5.2
    If the computer is re-booted, then it may work once but then crashes again next time the user tries to connect

    Affecting several laptops, all running Windows 10 Pro, 1909, Mobile VPN 12.5.2

    Deleting the folder mentioned above didn't resolve issue

    3 attempts at connecting, all hang on waiting for connection then returns to logon screen, logs are as follows for the 3 connection attemps

    2020-02-06T09:51:36.222 Launching WatchGuard Mobile VPN with SSL client. Version 12.5.2 (Build 606431) Built:Nov 4 2019 13:40:17
    2020-02-06T09:51:42.317 Requesting client configuration from #############
    2020-02-06T09:51:43.864 VERSION file is 5.33, client version is 5.33
    2020-02-06T09:51:44.364 LaunchOpenVPN: openvpn full command-line(first 8 chars): "C:\Prog, length: 248
    2020-02-06T09:51:44.364 LaunchOpenVPN: vpn config full path(first 8 chars): C:\Users, length: 57
    2020-02-06T09:51:44.895 OVPN:>INFO:OpenVPN Management Interface Version 1 -- type 'help' for more info

    There is a known issue listed whereas changing log level to debug is a work aroud, but this isn't working in my case either

    Article ID :000016567

    After changing to debug, logs are:

    2020-02-06T10:09:22.493 Launching WatchGuard Mobile VPN with SSL client. Version 12.5.2 (Build 606431) Built:Nov 4 2019 13:40:17
    2020-02-06T10:09:27.633 Requesting client configuration from ##########
    2020-02-06T10:09:29.133 VERSION file is 5.33, client version is 5.33
    2020-02-06T10:09:29.633 LaunchOpenVPN: openvpn full command-line(first 8 chars): "C:\Prog, length: 249
    2020-02-06T10:09:29.633 LaunchOpenVPN: vpn config full path(first 8 chars): C:\Users, length: 57
    2020-02-06T10:09:30.164 OVPN:>INFO:OpenVPN Management Interface Version 1 -- type 'help' for more info

    2020-02-06T10:09:30.164 OVPN:>LOG:1580983770,D,WE_CTL n=0 ev=01414158 rwflags=0x0001 arg=0x00000000

    2020-02-06T10:09:30.164 OVPN:>LOG:1580983770,D,WE_WAIT enter n=1 to=1000

    2020-02-06T10:09:30.164 OVPN:>LOG:1580983770,D,[0] ev=000001C0 rwflags=0x0001 arg=0x00000000

    2020-02-06T10:09:31.180 OVPN:>LOG:1580983771,D,WE_CTL n=0 ev=01414158 rwflags=0x0001 arg=0x00000000

    2020-02-06T10:09:31.180 OVPN:>LOG:1580983771,D,WE_WAIT enter n=1 to=1000

    2020-02-06T10:09:31.180 OVPN:>LOG:1580983771,D,[0] ev=000001C0 rwflags=0x0001 arg=0x00000000

    2020-02-06T10:09:32.195 OVPN:>LOG:1580983772,D,WE_CTL n=0 ev=01414158 rwflags=0x0001 arg=0x00000000

    2020-02-06T10:09:32.195 OVPN:>LOG:1580983772,D,WE_WAIT enter n=1 to=1000

    2020-02-06T10:09:32.195 OVPN:>LOG:1580983772,D,[0] ev=000001C0 rwflags=0x0001 arg=0x00000000

    2020-02-06T10:09:33.211 OVPN:>LOG:1580983773,D,WE_CTL n=0 ev=01414158 rwflags=0x0001 arg=0x00000000

    2020-02-06T10:09:33.211 OVPN:>LOG:1580983773,D,WE_WAIT enter n=1 to=1000

    2020-02-06T10:09:33.211 OVPN:>LOG:1580983773,D,[0] ev=000001C0 rwflags=0x0001 arg=0x00000000

    2020-02-06T10:09:34.226 OVPN:>LOG:1580983774,D,WE_CTL n=0 ev=01414158 rwflags=0x0001 arg=0x00000000

    2020-02-06T10:09:34.226 OVPN:>LOG:1580983774,D,WE_WAIT enter n=1 to=1000

    2020-02-06T10:09:34.226 OVPN:>LOG:1580983774,D,[0] ev=000001C0 rwflags=0x0001 arg=0x00000000

    2020-02-06T10:09:35.242 OVPN:>LOG:1580983775,,NOTE: --mute triggered...

    Simon

  • RalphRalph WatchGuard Representative

    Hello Simon,

    Please open a support case so we can understand if you're affected by the known issue. There's a new client being released in the next version which includes additional fixes.

  • edited March 23

    Hi, I'm having the same issue and I opened an issue but watchguard support tell me that they verified it a lot of times to connect to my firewall with SSLVPN and it was good for them, no stuck. Now I found this thread, so I assume you have identified the problem and are going to fix it? Is there any ETA? Is very anoying for a company with 400 users to restart app until it works and don't get stuck.
    We are on the latest version for both, firewall and SSLVPN Client.

  • James_CarsonJames_Carson WatchGuard Representative

    Hi @ILIMIT,

    What's the case number that you were working with support on. I can get it pulled up and we can take a look at it.

    -James Carson
    WatchGuard Customer Support

  • Hi @James_Carson,

    Thanks for answer, the case number is 01345631. We can share with you all the info that we have and all the test that have made.

    TY in advance.

  • Sorry for double post. This is the same issue we're having: https://community.watchguard.com/watchguard-community/discussion/811/sslvpn-stuck-on-waiting-for-connection
    Last workaround published by "trifecta" on March 20 worked for us, but not always.

  • James_CarsonJames_Carson WatchGuard Representative

    Hi @ILIMIT
    I've requested that your case be reviewed and I'll have them provide you an update as soon as they can.

    Thank you,

    -James Carson
    WatchGuard Customer Support

  • Hi, James, the update that you mean that is going to be release this week, is on the side of firewall (firewire) or vpn ssl client?. If I join beta program is possible to test it?
    I will attach you in the case my mobile number if you wanna call me. here is GMT +1 but you can call me until 23h GMT+1

    We made some tests today downgrading Mobile VPN SSL Client to 12.2 as suggested in my last post but only worked in few cases.

    Thanks for feedback,

  • I can confirm Watchguard VPN SSL client version 12.5.3 works like a charm now.
    We we're using ESET Endpoint too in our enviroment and I think this was the problem, because other users suggested this on another posts with the same issue:-->
    https://community.watchguard.com/watchguard-community/discussion/811/sslvpn-stuck-on-waiting-for-connection

    ESET published this note 3 days ago with new client: https://support.eset.com/en/kb7470-watchguard-mobile-vpn-connection-issue-with-eset-endpoint-antivirus-eset-endpoint-security

Sign In to comment.