UDP Timeout

Hi All,

Currently investigating an intermittent issue with Firebox running 12.10.1 with BT Cloud Voice Deskphones.

I have created a custom policy with the required ports for both signalling and RTP. Call work in both directions with 2 way audio. However the client reports that at random times the audio will stop but the call remains connected.

Therefore my feeling is this is some sort of timer. The one I am thinking of is one known as "UDP Timeout" with other vendors. On the Firebox I have the option for "Custom Timeout" which is unticked by default and when ticked I can set to 300s (the UDP Timeout setting requested by BT).

However is this the setting I think I am after? Some posts indicate that this setting only affects TCP whilst other tell me that UDP Timeout is only configurable globally via CLI?

An alternative approach is to configure a TCP-UDP proxy where I can configure the UDP Timeout from 30 to 300s However that doesn't allow me to get specific with ports?

Interested to know your thoughts.



  • Options

    "Custom Timeout" does only apply to TCP, and the only way to change the default default UDP timeout is via the CLI.

    The TCP-UDP proxy does let you get specific with source IP addrs/subnets, so you could have a policy which only applies to your phones. And you can disable the 7 proxy options and enable "Other Protocols".

    Coin flip - neither option to increase the UDP timeout for the phones is ideal, but try one.

    And, you can open a support case to get help from a WG rep to understand the apparent timeout issue.

  • Options
    Thanks for the reply. Super helpful!
Sign In to comment.