Watchguard M690 with Nagios Core integration problem

Hi all,
I'm coming to ask for help, I'm having a problem integrating the "Nagios Core" network monitoring environment with the Firebox M690 Watchguard running in a cluster.
I did this based on the watchguard documentation, I am throwing the link here:

I downloaded the Fireware OS compatible with the version of the device 12.10, after installing in the directory C:Users\PublicShared WatchGuard\SNMP MIBs appeared.
But they were in .txt form - I compared them with another mib and the file structure is correct.
I tried uploading them to nagios in .txt form as well after converting them to .mib form

I created a configuration file in nagios for watchguards and defined a service that checks the CPU utilization of the system in the last 1 minute.

check_command check_snmp! -C public -o -m all

I then configured SNMP in watchguard, set the community string, SNMP v1/v2c version and traps v2Trap and SNMP Management Stations to the nagios ip address.

Unfortunately, this did not work.

I checked with SNMP Tester if the oid returns any value, and it returns SNMP_EXCEPTION_NOSUCHINSTANCE223.

----------------------- New Test ----------------------- Paessler SNMP Tester - Computername: TERMINAL 14.11.2023 09:05:25 (71 ms) : Device: 14.11.2023 09:05:25 (96 ms) : SNMP v2c 14.11.2023 09:05:25 (116 ms) : Custom OID 14.11.2023 09:05:25 (267 ms) : SNMP Datatype: SNMP_EXCEPTION_NOSUCHINSTANCE 14.11.2023 09:05:25 (290 ms) : ------- 14.11.2023 09:05:25 (313 ms) : Value: #N SNMP_EXCEPTION_NOSUCHINSTANCE223 14.11.2023 09:05:25 (340 ms) : Done


Then I found, in the article attached above, information about third party mibs., I checked the mib which result should be "CPU 1 minute load"

And it returns the correct value.

----------------------- New Test ----------------------- Paessler SNMP Tester - Computername: TERMINAL 14.11.2023 09:09:27 (78 ms) : Device: 14.11.2023 09:09:27 (108 ms) : SNMP v2c 14.11.2023 09:09:27 (140 ms) : Custom OID 14.11.2023 09:09:27 (319 ms) : SNMP Datatype: ASN_OCTET_STR 14.11.2023 09:09:27 (347 ms) : ------- 14.11.2023 09:09:27 (368 ms) : Value: 0.24 14.11.2023 09:09:27 (390 ms) : Done

I have uploaded UCD-SNMP-MIB to nagios and I still get the error "CRITICAL - Plugin timed out while executing system call".

This is where I come in for help. Maybe someone has an idea and is able to point me in a direction of where I can get this to work then I would greatly appreciate it.


  • Options
    james.carsonjames.carson Moderator, WatchGuard Representative

    Hi @toloxus

    If you're able to get a value using a tool like smnpwalk, Nagios shouldn't be doing anything different. The queries will just be snmp to the firebox, like any other snmp query.

    -Check to ensure that the firebox is allowing snmp traffic from the Nagios server to "firebox" if Nagios lives somewhere other than where you're testing from.

    -If you have allow logging enabled for your SNMP policy on the firewall, do you see allow lines when the Nagios server attempts to query the Firebox?

    If you're able to do an snmpwalk for that value from the same IP as the Nagios server, then there's likely something going on with Nagios, and you'll want to check with their support for help with that.

    -James Carson
    WatchGuard Customer Support

Sign In to comment.