SMTP-Proxy blocking unicode email addresses

Using an m290 firebox on 12.9 fireware. We have a new employee with a unicode character in his email address ( ñ or ALT+0241 ). When I have the smtp-proxy active, test email from gmail results in delivery failure with notice that SMTPUTF8 is not supported. When I disable the smtp-proxy and just enable a generic smtp rule, the email goes through just fine, verifying that it is the proxy blocking the address. I cannot find anything in the proxy configuration that will allow for unicode characters in an email address. I do have the "Block 8-bit characters" unchecked for the Rcpt To under addresses.

Any ideas?


  • Options
    james.carsonjames.carson Moderator, WatchGuard Representative

    Hi @Bryan_Palmer

    At this current time, the SMTP proxy doesn't support SMTPUTF8 (RFC6531) addresses. There is a feature request (FBX-16860) but there is not currently a targeted release version or ETA. If you'd like to follow that request, please create a support case and mention FBX-16860 in the case somewhere.

    Unfouranetely, at this time the smtp proxy will not be able to process traffic involving that user.

    The best solution I can think of at this time would be to change the user's primary email address to one without the ñ, and create an alias for the user that points both the address with and without the ñ at the same mailbox. That would allow them to get email now, but also use the better one once that is available without having to change anything.

    -James Carson
    WatchGuard Customer Support

Sign In to comment.