VPN & RDP with multiple monitors

I have 2 monitors at work connected to m work computer, but when I RDP to the work computer from home, it combines both monitors into 1 RDP. I'm using Windows 10 at home.

I have 'Use all my monitors for the remote session' checked. This is what I'm trying to do, but not working. Any suggestions?



  • Options
    james.carsonjames.carson Moderator, WatchGuard Representative

    Hi @tantony

    If you're using the windows remote desktop client, it's likely a compatibility issue on either your home or work PC. The firebox doesn't do anything that can restrict RDP traffic in that way. Multi-monitor does require you be in full screen mode -- if there's too much screen for the work PC to render it might simply not let you do that.

    If you're using Access Portal, the rendering engine that runs on the firewall for RDP via the browser only supports one screen at this time.

    -James Carson
    WatchGuard Customer Support

  • Options

    ok thank you, I was just checking to see if there's a Windows setting.

Sign In to comment.