Policy Manager can´t save altered files to FB

Hi all,

i´m experiencing some strange behaviour:

after updating the WSM-Tools on my Win11-Admin-PC, now when i fetch the config from a FB , change some settings and want to write these changes back i only get this strange Error-Message:

Operation failed. Comparison method violates its general contract!

Any idea, what this could be ?

Re-installation of the toolset made no difference.

Alternative PC does work. ...

many thanks in advance,



  • Options

    For the record, from what version of WSM did you upgrade, to what version?

  • Options
    edited October 2022

    An Internet search on this error indicates that it is a Java error.
    Possibly related to the JDK version.

    You should open a support case so that a WG rep can help sort this out.

  • Options

    Hi Bruce, i updated from 12.8 to 12.8.2 (latest) yesterday

  • Options
    james.carsonjames.carson Moderator, WatchGuard Representative

    Hi @Ludwig_Beck_80331
    I would suggest opening a support case for this issue so we can see what WSM is getting hung up on.

    If possible when you create the case, please do the following:
    -Open up WSM and log in.
    -Launch Firebox System Manager and go to the status report page. Click pause at the bottom of that page, and then click the support button at the bottom left of the page. Specify a place to save a support file, but do not press retrieve yet.
    -Open Policy manager and attempt to get the error to occur again.
    -Press retrieve back in Firebox System Manager as soon as the pop-up error happens.
    -Please attach that support.tgz file to your case. It should contain more information about the error that we can analyze.

    -James Carson
    WatchGuard Customer Support

  • Options
    edited October 2023

    Hello, I have had exactly the same problem for two days,

    I had already opened a support ticket in December 2022 where the solution was to remove the WatchGuard System manager add-on and delete the %APPDATA%\WatchGUard\ folder then reinstall WSM, which worked.

    I tried to do the same method again without success.

    WSM 12.10

  • Options
    james.carsonjames.carson Moderator, WatchGuard Representative

    Hi @DGI_Geoffrey
    The most common problem I encounter when customers are unable to save is that the save dialogue may hang if there are a large number of mapped network drives on your system. If the window simply isn't coming up, try leaving it for awhile, it will eventually time out and pop-up. You can also try disconnecting network drives if they're currently connected.

    If that does not work, I'd suggest opening a new support case and including the logs from that same folder, if there are any.

    -James Carson
    WatchGuard Customer Support

Sign In to comment.