"Video unavailable" YouTube when behind firewall for some videos

Recently some users have experienced this error for some YouTube videos, when PC is behind firebox, but not when directly on public internet w/o firebox in-between. Same behavior in incognito windows and with new Edge.

"Video unavailable"
"This video is restricted. Please check the Google Workspace administrator and/or the network administrator restrictions."

Sample page: https://thenationalrealestatepost.com/the-great-depression-in-housing/

The settings do not appear to be delivered via GPO and only occur when behind the firebox.

I do use a WSM server to manage the firewall settings with templates.

I did uncheck:
Proxy Action --> HTTP Request --> General Settings --> SafeSearch --> "Enforce SafeSearch"
I thought that it would address the issue, but it did not.

Please let me know your thoughts.



  • james.carsonjames.carson Moderator, WatchGuard Representative

    Hi @Logan5
    Have you tried using a different browser?
    If safesearch is being forced off, the firewall should not be forcing on any feature like this. In chrome, settings like this can be enforced via group policy as well.

    -James Carson
    WatchGuard Customer Support

  • The settings do not appear to be delivered by GPO - check in gpresult. Incognito sessions and Edge browser are impacted too. We have never, ever had any GPOs for Edge. The same PC is only impacted inside of the firewall. It is fine outside of the firewall.

  • james.carsonjames.carson Moderator, WatchGuard Representative

    Without seeing the settings on the firewall itself, it's difficult to tell you where to go next -- I'd suggest opening a support case so that one of our techs can assist.

    -James Carson
    WatchGuard Customer Support

  • I opened a case at the same time, but had not heard anything from WG support yet.

    I may have now found a solution. I am still validating, but I think that the issue stems from a setting in DNSWatch, which is tied to the firewalls.

    What keyed me to it was I check the YouTube content restrictions page:
    It showed "Strict" in the 'DNS restrictions' column, but the 'HTTP header restrictions' column was blank. Once I saw DNS, I began to think about DNSWatch, because it has been a fairly "set it and forget it" technology. I obviously forgot about it too long.

    Within 10 minutes of changing the setting. The YouTube "Restricted Mode" set to 'Off'. I could then turn it on/off manually, if I wanted. It was no longer a locked/grey setting.

    Here is where I found the DNSWatch setting.
    (I removed the 'YouTube' checkbox, saved and updated the policy.)

  • james.carsonjames.carson Moderator, WatchGuard Representative

    Do you happen to have a case number -- I can make sure it lands with the correct team.

    The DNSWatch option uses a redirect, and how long it takes the clients to get that update will depend on how long it takes them to do a DNS lookup for that again.

    -James Carson
    WatchGuard Customer Support

  • James, I closed out the case: 01745348

Sign In to comment.