WSM Report Server not generating reports

Hi.

I have to admit that I'm absolutely new to WSM report server, so I guess I miss anything obvious.

For testing I have created a new daily schedule including all records and all devices to run 5 minutes in the future. In the logs (I set level to "information") I see that the schedule is executed an that are no errors reported.

However I do not find any reports in the web front end.

In contrast when running a "On-Demand" reports, it works and also displays the data which I expected.

What I'm missing?

THX and kind Regards
offbyone

Best Answers

  • Accepted Answer

    It has been a very long time since I used WSM Reports. I have been using Dimension since.

    I ran a daily report, and as I recall, it was for 24 hours, and I think that it was for 0:00 AM to 11:59 PM.
    I believe that I scheduled mine for 2 AM.

    Been many years - the details are a little fuzzy.

    Check your Report Manager in a few hours and see if anything is there. If not, check tomorrow.

  • edited June 4 Accepted Answer

    Indeed today morning the reports for yesterday are available.
    To sum it up: When a schedule is executed it creates the daily report with the data from the day before 00:00 AM to 11:59 PM. So for the first schedule to run you have to wait at least until midnight.

    Thanks a lot for pushing me into the right direction.

    Cheers.

Answers

  • Exactly where did you set level to "information" ?
    WSC -> Management Server -> Logging ?

  • WatchGuard Server Center -> Report Server -> Logging -> File path -> Set a log level.

    We do not have a "Management Server" setup. Only "Log Server" and "Report Server"

  • That setting refers to log messages from the Log Server itself.
    If there are no log message generated by the Log server to date, then there is nothing on which to report.
    If there are log messages, one would see them in the Log Manager -> Servers selection, not the Devices selection.
    And for Reports, one would see then in Report Manager -> Servers

  • That setting refers to log messages from the Log Server itself.

    AFAIK these are the log messages from the Report Server itself? I set this to see if the Report Server is executing the schedule which it does.

    I think I was not precise enough, sorry for that.

    I have a Firebox which send it's logs to the Log Server. This works. I can see the Firebox device and also the log messages from "WebCenter Log Manager".

    And now I want to have some reports for this Firebox. I see that the Firebox is included in the report schedule ("All Devices" selected) and also all WatchGuard reports are selected.

    But after the Schedule finished I see no reports at all.

    In contrast if I execute a "On-Demand" report from "WebCenter Report Manager" for this device I get a report as expected.

  • It takes a while for a scheduled report to be generated.
    It includes 24 hours of logs, and you have selected all of the reports.
    How long has it been since the scheduled time for the reports to be generated?

  • I setup a new server and cause I wanted to see if it works I set the schedule **day **to yesterday and the schedule **time **to 5 minutes in the future. Then I waited until the schedule finished.

  • edited June 3

    While reading your post I thought it may be a good time to rethink my assumption on the scheduling logic.

    What is considered a daily report (what data is included).
    From 0:00 AM to 11:59 PM?
    or
    From schedule time of previous day to schedule time of day of schedule?

  • I will wait, check and report back.

    THX a lot for your help

  • James_CarsonJames_Carson Moderator, WatchGuard Representative

    I would suggest looking into Dimension if you haven't already. Log/Report server hasn't gotten any updates for a number of years and has been supersceeded by Dimension.

    -James Carson
    WatchGuard Customer Support

  • Do note that Dimension 2.0 and newer does require a current LiveSecurity license on the logging firewall, whereas WSM Log & Report servers do not.

  • Hi Bruce.

    Thanks for pointing that out.

Sign In to comment.