IPv6 Use delegated prefix not working

T55, v12.5.2

External interface is connected to Spectrum residential cable modem. IPv6 is enabled on the interface with these settings enabled:
IP Address Autoconfiguration
Enable DHCPv6 Client
Enable DHCPv6 Client Prefix Delegation

The interface is getting an IPv6 address and prefix from the ISP correctly:
Prefix: 2603:900a:1402:e183::/64

On the trusted interface IPv6 is enabled. Use delegated prefix is selected in the Add Static IPv6 Address dialog box. The IP Address field looks like:
eth0_prefix ::1:1:1:1 / 64
Add Prefix Advertisement is also selected

After saving the config, no static IP address is assigned to the Trusted interface. The Front Panel tab in FSM shows eth1 > IPv6 Address > Assignment: Static but no address is shown (besides the link-local address).

Likewise, no clients on the trusted network are obtaining an IPv6 address from the device.

Is there possibly an issue with the fact that I'm getting a /64 prefix from my ISP as opposed to a /48 or /56?


  • Options

    I am having the same problem. Setting a static prefix and IP works fine, but using the prefix assigned to eth0 is not working.

  • Options

    I am attempting to configure this to a bridge. In the past it has worked when configuring a VLAN.
    Neither works now from either Policy Manager or the web interface.

  • Options
    edited June 2021

    It works.
    You can't use the full prefix delegation. I set my interface to eth0_prefix::e000:0:0:ffff/67, and the address now correctly shows in the System Manager window.

  • Options

    Requesting a larger prefix delegation is in defect/enhancement request FBX-4951 from 2017. Submit a support ticket if this is a feature you would like to see in a future firmware release.

Sign In to comment.