Viber desktop is not working

I am trying to find out how to make viber desktop working. It is allowed in application control settings.
It is working when HTTPS inspection is disabled. But when is enabled it doesn't sync. I tried adding domain exceptions(*, * in the https proxy inspection but it is still not working.
Do you have suggestion how to configure the inspection so Viber will works but also the inspection for the other sites remains?



  • james.carsonjames.carson Moderator, WatchGuard Representative

    Hi @BorisS

    I'd suggest trying to make an HTTPS packet filter. In the from area, use any-trusted or the computer you're testing from, and in To, use a FQDN of the two sites.

    If that doesn't work, there may be other sites you need to make exceptions for. If you have logging enabled for your proxy, you should see the requests for the sites it's trying to go to. You can also use the developer options in Chrome, Firefox, etc to see what sites the website is pulling from (usually the network tab.)

    Failing all of that, opening a support case (using the support center link at the top of the page) can get one of our technicians to work this issue with you.

    Thank you,

    -James Carson
    WatchGuard Customer Support

  • Hello James, thanks for your reply. The thing is that I am not sure which domain is viber using. I tried also with the the aws Amazon group but is still the same.
    In the error log the request is as follows:
    Domain: N/A PFS: ALLOWED
    Maybe firebox doesn’t recognise the domain and that’s the issue?
    I am asking here because maybe there are others who solved this issue already.
  • james.carsonjames.carson Moderator, WatchGuard Representative

    Hi @BorisS

    If you're seeing that log, that's the domain that the firewall is reading off of the certificate that's being presented. In this case, the cert may not have a domain.

    Making an FQDN rule may still help, but if you're not getting anywhere with that I'd suggest a support case.

    -James Carson
    WatchGuard Customer Support

Sign In to comment.