FQDN for devices on network

Hi,

I'm trying to get devices on my network to show up as FQDN.

I have entered in a domain name under my dhcp settings for the network, and that seems to work - e.g. ipconfig on a windows machine shows the line: Connection-specific DNS Suffix . : mydomain.name

Right now I can ping hostnames just fine, but not if I append this domain name. for example:

ping deviceA - this works
ping deviceA.mydomain.name - this does not work

What am I doing wrong?

Comments

  • edited May 20

    Verify that your PC has the domain name suffix in its interface settings.

    In a CMD box, enter:
    ipconfig /all

    If not, either reboot your PC or in a CMD box, do:
    ipconfig /release
    ipconfig /renew

  • Thanks Bruce.

    The DNS suffix is indeed there on the machine that I'm pinging from and to.

  • My Window 10 PC shows a DNS lookup being attempted for a ping to a host name with the DNS suffix appended to the host name entered.
    So you need a real local DNS to do FQDN resolutions.
    XTM is not a DNS server. It can only be a DNS forwarder, if this option is enabled.

Sign In to comment.