Copy & Paste doesn't work

Using Authpoint to connect to an RDP session via the browser I am unable to copy and paste from my laptop into the session and vice versa. As a workaround I copy and paste twice, using the settings> clip board option but this isn't very graceful and not useful if copying lots of excel data for example.
Any ideas?


  • james.carsonjames.carson Moderator, WatchGuard Representative

    Hi @notesguru99

    This is a limitation due to the session being rendered on the firewall and it being streamed to you (the user.) Most browsers won't allow data to be pasted directly into a stream like that. The workaround is to provide the clipboard area, which we can send to the server.

    -James Carson
    WatchGuard Customer Support

  • Thanks for the reply James, I feared that might be the answer! Is there any way I can use RDP native app with Authpoint or does it have to be the web session?

  • james.carsonjames.carson Moderator, WatchGuard Representative

    Access Portal replaces the native app. If you'd prefer to use the native (mstsc.exe) app, you'll need a way to access your internal network. The firebox offers several VPN options (SSL, IKEv2, L2TP) that can allow this.

    You'd connect to the VPN, then use the native app to connect to whatever server you're attempting to connect to.

    -James Carson
    WatchGuard Customer Support

  • Also, you could set up WG authentication, enabled on external, and then allow RDP connections From: an authenticated user ID

  • Thanks both, we used to do that, SNAT through using Watchguard authentication, but I want to use AuthPoint and 2FA as this service is only for 3rd parties, so the beauty of Authpoint is that they manage their external identities and then we allow them access to our servers and they do not need to know the password for the user of said server. Could I create a policy for this one 3rd party user so from 'external user' to 'internal RDS' - would that work after they have authenticated using AuthPoint and 2FA?

Sign In to comment.