Access Portal error with RDP "Upstream Not Found"

Hello guys, hope you are doing well, I need some help with an error in our infrastructure. Our goal is to allow people from outside trought the access portal susbcriptions service to access into a RDP server.

It show me "Upstream not found", Did you guys ever have this error? I check the case sensitive configuration and it's ok, also, protocol configured as RDP and to asking for the password.


  • Just had it this week.
    If you are using the Access Portal to RDP onto PC's make sure the PC is turned on and you have the correct IP address to the PC configured in the Access Portal.
    Had a power outage over the weekend that shut down a lot of PC's and the users got this error until their PC was turned back on.

    • Doug

    It's usually something simple.

  • Hi doug, we have a terminal server in this case.

  • Is it turned on?

    Ha! :D

    It's usually something simple.

  • james.carsonjames.carson Moderator, WatchGuard Representative

    This generally means the device sending the stream isn't for some reason. Reasons range from firewall, to connection time out, failure, etc. It'll usually be best to check the RDP process logs/events on the server to see why.

    -James Carson
    WatchGuard Customer Support

  • Thanks @james.carson I will check that

  • I have the same issue - we use the WG portal to access a virtual machine and even though it is on we get the error - the workaround is to open the vmware remote console of the server and then the portal link works? Any ideas how to fix this permanantly?

  • james.carsonjames.carson Moderator, WatchGuard Representative

    Hi @stuart_seed
    I'd suggest opening a support case on this, so that we can look into this.

    -James Carson
    WatchGuard Customer Support

  • IF you use TLS as security type try the following:
    If you select TLS, you must change the Remote Settings in Windows so Allow connections only from computers running Remote Desktop with Network Level Authentication is not selected.

Sign In to comment.