saving a default "server" IP in firebox ssl mobile VPN

hi,
so every new user on a laptop has to type in the Server IP at the moment - can this be fixed to something default or can it be run with a command line to use a given IP and port?

thanks

Comments

    1. "the Server IP at the moment" - does the IP addr of the firewall change ?
      If so you can set up DYNDNS on your firewall so that access can be by domain name instead of by IP addr.

    2. the IP addr or domain name and port is saved in the client.ovpn file
      Review this FAQ:
      Users cannot download the Mobile VPN with SSL configuration from the Firebox
      https://watchguardsupport.secure.force.com/publicKB?type=KBArticle&SFDCID=kA2A00000000FkRKAU&lang=en_US

  • Assuming these are Windows laptops, if your laptop users have permission to run .REG files to populate the registry, then you could create a .REG file and populate it with the target IP, or better yet, use the FQDN of the Firebox, and have public DNS for that FQDN pointing to the WAN IP of the Firebox. Put that .REG file in C:\Drivers and create a read-only shortcut to it in the Public Desktop folder.

    For example, modify the Server target below, and create a file using the text in between the dotted lines below.


    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\WatchGuard\SSLVPNClient\Settings]

    "Server"="vpn.yourpublicdomainname.com"

    Gregg Hill

    Firebox T15/T35-W
    Fireware 12.5.1 build 601804
    WSM 12.5.1 build 601717
    ISP = Spectrum Cable 100 x 10 service
    Management computers: Win 8.1 Pro 64-bit, Win 10 Pro 64-bit, Server 2012 R2

  • edited August 6

    Hi,
    how exactly should the file look?

    I did create a file.REG looking like this:
    [HKEY_CURRENT_USER\Software\WatchGuard\SSLVPNClient\Settings]
    "Server"="vpn.mycompany.com"

    But when I run it I get "cannot import file.REG The specified file is not a registry script, you can only import binary reg files from within the reg. editor"

  • The 1st line in the file needs to be:
    Windows Registry Editor Version 5.00

  • Did you use what I noted in between the lines? It has the complete text.

    Gregg Hill

    Firebox T15/T35-W
    Fireware 12.5.1 build 601804
    WSM 12.5.1 build 601717
    ISP = Spectrum Cable 100 x 10 service
    Management computers: Win 8.1 Pro 64-bit, Win 10 Pro 64-bit, Server 2012 R2

  • @Bruce_Briggs said:
    The 1st line in the file needs to be:
    Windows Registry Editor Version 5.00

    Thanks, it works now!

  • @GreggHill said:
    Did you use what I noted in between the lines? It has the complete text.

    No sorry I did not, I see it now - thanks!

  • edited August 7

    It would be nice to add the current user also as the username, I did try adding the line
    "Username"=%USERNAME%
    But it didn´t work, if I just put
    "Username"="donald.duck"
    It works fine!

    Any ideas how to put the logged on user name?

    /Martin

Sign In to comment.